Trouble compiling

Post here if you need help using Actiona
Post Reply
hfx10
Posts: 5
Joined: 21 Nov 2021, 20:40

Trouble compiling

Post by hfx10 »

I really like actiona but am no longer running a Debian based distro and so I need to compile it from source. The instructions say to use

Code: Select all

qmake -r
to get a make file, but I don't think this is correct as it appears I now need to use cmake instead? I'm not very familiar with cmake and so I'm not sure how to proceed. Any help would be appreciated.
eureka
Posts: 152
Joined: 08 Mar 2016, 22:18

Re: Trouble compiling

Post by eureka »

You do not mention your distro/version.
Last time I compiled from source (on Ubuntu some time ago) I used QtCreator.

https://doc.qt.io/qtcreator/creator-project-other.html

Qt and QtCreator admittedly is a lengthy installation but offers lots of flexibility to customise.

Another option is to build on a VirtualBox virtual machine but I have not done that.
hfx10
Posts: 5
Joined: 21 Nov 2021, 20:40

Re: Trouble compiling

Post by hfx10 »

I'm using gentoo. Looks like qt creator is available so I might try that, otherwise I might try with virtual box, thanks for the suggestions.
hfx10
Posts: 5
Joined: 21 Nov 2021, 20:40

Re: Trouble compiling

Post by hfx10 »

Ok so after tiinkering around a bit and installing a bunch of qt stuff, I got it to generate a make file with

Code: Select all

cmake . 
, and then

Code: Select all

make
didn't report any errors. Unfortunately, when trying to launch I get a segmentation fault.
eureka
Posts: 152
Joined: 08 Mar 2016, 22:18

Re: Trouble compiling

Post by eureka »

Can you post the actual error message.

My last attempt yp build was some years ago.

viewtopic.php?f=35&t=9711&p=23431&hilit=qmake#p23431

Check that you can installed all Qt dependencies.
hfx10
Posts: 5
Joined: 21 Nov 2021, 20:40

Re: Trouble compiling

Post by hfx10 »

I'm pretty sure I installed everything from here https://gitweb.gentoo.org/proj/qt.git/tree/sets except for qtwebengine as it takes a really long time to compile. It's possible one of the packages needs some USE flag I don't have enabled but that's going to be hard to diagnose.

When trying to launch actiona, 'segmentation fault' is the only error that appears in the terminal. I'm not sure if there is any way for me to get more information. I've also tried to build a simple AppImage from Debian, this also leads to a segmentation fault on gentoo, so I'm most likely missing some .so file. I was thinking of trying to build an AppImage with all required libraries built into the AppImage, that looks like it would be a big task though. Also ran it through wine but it does not manage to get control of the cursor through wine.
hfx10
Posts: 5
Joined: 21 Nov 2021, 20:40

Re: Trouble compiling

Post by hfx10 »

Ok so I've figured out the issue, I forgot that not everything works with xwayland... It works just fine under i3, not sure if it's possible to run with wayland but at least now I know it's compiled correctly and all dependencies are there.
Post Reply